INAV PARTE 1 Firmware y configurador

Contenido solo accesible para usuarios , Registrate.

40 comentarios en «INAV PARTE 1 Firmware y configurador»

  1. Hola,

    Estoy con una matek f411 wing, le he instalado el firmware todo bien, una vez instalado le doy al boton de conectar e inav se va a la ultima pestaña, CLI, y no puedo hacer nada mas, solo pudeo poner exit o help, y no se que debo haver y avanzar, alguna ayuda por favor.

    Gracias.

  2. Hola,sigo con el problema de conexión ,.me deja falsear todas las veces que quiera y distintas versiones ,borrando la anterior.
    Pero a la hora de conectar para calibrar,me da error por exceder en más de 10sg.
    Perdona que sea un pesado, pero ya no se lo que hacer.
    Saludos
    Esteban

    • Hola Esteban, pues hemos probado casi todo… asegúrate de que el firmware que se esta instalando es el correcto.. también puedes verificar si te esta detectando MPU6500 … en caso de que sea así.. Debe ser MPU6000. mira que no te salga en ningún parámetro Hardware fail.. porque de ser así… si no se nos escapa algún detalle mas ,, puede que sea un error de hardware.. y que el acelerometro este fallando.. revisa lo del MPU a ver si hay suerte.. un saludo.

        • Hola Esteban.. el Mpu es el acelerometro/giroscopio. en la F405 wing es el mpu6000 si que he visto casos que el frimware lo codifica como mpu6500 y da fallo.. haz una cosa.Conecta todo como si fueras a volar. . En la pestaña cli.. escribe lo siguiente..
          STATUS. y pulsas enter.. a continuación escribe DUMP y pulsas enter.. y el resultado lo guardas en un archivo TXT. y me lo envías por mail.. que intentare leerlo .. y ver si puedo ver algo.
          un saludo

          • Buenos días Ángel
            Gracias por apoyo.
            Me he metido en las características de la placa y pone que lleva montado un MPU9250
            Que puedo hacer?
            Saludos
            Esteban

      • Hola de nuevo. si lo unico que puedes hacer para ver si te puedo ayudar es lo que te he pedido en el otro comentario .Dime tambien que controladora estas usando exactamente porque la F405 wing usa mpu6000. un saludo

  3. Hola, buenos dias, me he dado cuenta que al abrir el Progama Inav, aparece a la izquierda y debajo del logo(cuadrilátero) versión 2.3.
    Yo he descargado la 2.2.1.¿Será este el motivo por el que no puedo entrar en calibración?
    Cuando conecto me da fallo por exceder de 10sg. y ya he probado en tres ordenadores distintos y cambiado el cable; como me aconsejastes.
    Saludos
    Esteban

    • Hola Esteban. Si posiblemente sea eso.. la versión del firmware debe ir acorde con la versión del configurador. Creo que te lo había puesto. Espero que sea este el problema y ya des con la solución.. igualmente.. si te sigue fallando puede que no se instalara bien el frimware.. entra en modo DFU y vuelve a reinstalarselo por si acaso. un saludo .

      • Hola,gracias por tu atención,pero sea la versión que sea no tengo forma de entrar en calibración, otro ordenador otro cable; versiones de la 2.2.. a la 2.4 ,al conectar siempre de error por exceder de más de 10 segundos.
        Saludos
        Esteban

        • Hola Esteban.. Deberás entrar en la placa en modo DFU y volver a cargar el firmware. tiene pinta de que no se ha cargado bien. Asegúrate de marcar la casilla ERASE ALL para que borre completamente el firmware anterior..
          un saludo

  4. Buenos días Angel. He seguido tus consejos, he cambiado el cable y conectado a otro ordenador. La versión que tengo es la 2.2.1, un puerto COM y varios puertos virtuales. Voy probando en cada uno de ellos y en todos el mismo mensaje: ” No cofiguration relieves sitúan 10 redondascommunications falles”.
    Ya no se por donde seguir ¿ Me puedes ayudar?
    Perdona por la lata que estoy dando y gracias por tu ayuda.
    Saludos
    Esteban

    • Si , al instalar la nueva versión te hace una instalación limpia. Puedes hacer un DUMP en el cli. para sacar toda su configuración. Y después de actualizar volver a cargar el dump en la nueva para dejarlo todo como lo tenias configurado.
      un saludo

  5. Una consulta, instalando el variador del motor cerca de la matek le generará alguna interferencia a la placa o no hay problema.
    Y los cables de receptor, vtx, camara y gps tienen que ser blindados o no es necesario.
    Gracias.

  6. Hola, muy bueno el tutorial, quisiera saber si la controladora matek F405 Wing se puede instalar en cualquier posision en el modelo o solamente hacia donde indica la flecha que esta en la placa, y una vez instalada en el modelo, para conseguir el nivelado correcto entre la placa y el modelo, se puede corregir con inav o hay que corregir moviendo la placa manualmente los grados que necesite.
    Gracias, saludos.

  7. Tengo una f4 para inav pero no consigo que el receptor dela emisora futaba en sbus lo reconozca la FC y está colocada en el uart3 que es donde dice el proveedor
    E revisado conexión y todo enciende correctamente que puede ser

  8. Gracias por la respuesta.
    Lo del CLI también lo había probado pero sin éxito tampoco.
    Al final era un problema de puertos. He estado investigando un poco y comento aquí como lo he solucionado pro si a alguien le sucede lo mismo.
    Al parecer hay dos tipos de puertos en el PC, los CP2102 y los VCP. Los primeros son los que usaban las viejas controladoras que utilizo en los drones tipo F3 y F4 y utilizan drivers distintos a los VCP. Por eso me funcionaban bien las FC de los drones pero no la Matek. Por lo visto las nuevas FC, (la F405 entre ellas) utiliza puerto COM virtual VCP y los drivers son otros. He ejecutado una aplicación llamada “impulse RC” que me ha instalado los nuevos drivers y ya puedo entrar en modo DFU.
    Muchas gracias y un saludo

  9. Hola,
    muchas gracias por este magnífico tutorial.
    Te comento mi problema a ver si me podeis ayudar.
    Acabo de adquirir una MAtek F405 wing y no consigo conectrla en modo DFU por lo que no puedo flashearla al ultimo firmware.
    En modo normal si conecta en COM5 pero no puedo configurarla porque no tengo el firmware más reciente.
    Estoy usando el ultimo configurador 2.1.3 y tengo todos los drivers instalados (vengo de los drones con betaflight y sin problemas hasta ahora).
    Ya no se que más probar, estoy perdido
    Que puedo estar haciendo mal?
    Muchas gracias

    • Hola Angel, gracias por tu comentario. Si no consigues poner la controladora en modo DFU apretando el botón, (recuerda debes mantener el botón pulsado antes de conectar el USB) . Pero si te conecta via puerto COM. Lo que puedes hacer es en la pestaña CLI escribir DFU y pulsar enter. Entrara en modo DFU automáticamente. Saludos

      • Hola, he actualizado la Matek 405 sin problema, pero al conectarla para calibración me da fallo ( más de 10 sg)..He usado Zadig,impulse RC.
        Con este último, me aparece Mateo en Administración de dispositivos, pero sigo sin poder entrar.
        ¿ Me podéis ayudar?
        Gracias por vuestra atención
        Saludos
        Esteban

        • Hola Esteban. Prueba a cambiar el cable usb… si así no consigues entrar.. deberías probar otro pc para descartar el problema de drivers… en caso de no poder tendrás que volver a reflashear tu controladora.
          un saludo. Si la actualización de tu controladora es a la nueva versión 2.4. tendrás que instalar el configurador 2.4 .. recuerda que esta versión todavía es de pruebas.. no es la versión final. Un saludo.

          • Hola,buenos días,siguiendo tus consejos, he cambiado el cable y he probado en otro ordenador.
            Sigo sin poder conectar la controladora.
            En Administrador de dispositivos me reconoce la Matek 405 y en los puertos COM, está COM3, pero sigue dando fallo.

            Saludos
            Esteban

Deja un comentario

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies